FC2ブログ

下流ネットワークエンジニアの生活

上流工程を夢見る下流工程のネットワークエンジニアがネットワーク技術や資格、身の回りのことを情報発信! Juniper Cisco YAMAHA DELL D-Link AlaxalA F5 CCNA CCNP CCIE ネットワークスペシャリスト

指定期間 の記事一覧

Cisco CatalystスイッチでIOSが破損してしまった時の復旧手順

2013.11.30 (Sat)
IOSが何らかの原因により、
読み込み不可となった場合、
rommonが起動する。

rommon起動時のプロンプトは
"switch:"

※正常時にrommonを起動したいときは
 電源投入時にMODEボタンを長押しする。






■復旧手順


xmodem新しいIOSファイルの転送準備


switch: copy xmodem: flash:ファイル名



●シリアルポートの転送速度の変更
※defaultの9600だと遅いので、
 転送前に転送速度を変えておく。

※115200だと約30分かかる

switch: set BAUD 115200




●Teratermの設定変更
転送速度を変えたらTeratermの設定も変える必要がある

「設定」→「シリアルポート」



「ボーレート」を115200に変更し、OKをクリック





●Flashをイニシャライズ

switch:flash_init




●ファイル転送を開始

「Tera Term Proメニュー」 → 「ファイル」 → 「転送」 →
「XMODEM」 → 「送信」 → 「ファイルを指定(転送開始)」



これでファイルの転送が始まる。



●転送が完了後、ファイルの確認

switch: dir flash:</span>


●転送速度を元(9600)に戻す

switch: set BAUD 9600
switch: flash_init




●転送したIOSで起動

switch: boot flash:ファイル名



よろしければクリックをお願いします。
にほんブログ村 IT技術ブログ ネットワーク・SEへブログ王ランキングに参加中!



スポンサーサイト



Juniper Networks JUNOS の J-Web に任意のコードを実行される問題

2013.11.29 (Fri)
J-Web の処理が原因でセキュリティホールの存在が公表された。

このセキュリティホールを利用された場合、
認証された攻撃者に任意のコードを実行される可能性があるとのこと。

これは Juniper Networks Junos OS の J-Web において、
jsdm・ajax・port.php のパラメータの処理を適切に行っていないため、
任意のコードを実行できることが原因。

この問題によりシステムはJ-Webの認証された攻撃者に
細工されたリクエストを送信されることで、
システム上で任意のコードを実行されたり、
他のユーザのセッション ID を読み取られたりする可能性がある。


※この問題はJ-Webを有効にしている場合にのみ影響を受ける。


■影響を受けるバージョン

12.3
12.2
12.1
11.4
10.4







■対処方法

・12.3
→Junos OS 12.3R1アップデート

・12.2
 →Junos OS 12.2R3アップデート

・12.1
 →Junos OS 12.1R5アップデート

・11.4
 →Junos OS 11.4R7アップデート

・10.4
 →Junos OS 10.4R13にアップデート



●バージョンアップ以外の一時回避策

J-Webを無効にする。

J-Webへのアクセスを信頼できるホストにのみ制限する。



応援クリックをお願いします。
にほんブログ村 IT技術ブログ ネットワーク・SEへブログ王ランキングに参加中!



Cisco Catalystスイッチ リンクアグリゲーション(LAG)

2013.11.29 (Fri)

リンクアグリゲーションとは

複数の物理的な回線を仮想的に束ね、
1本の回線として扱う技術

IEEE P802.3adにて規定

リンクアグリゲーションを使用することで、
物理回線の使用帯域を合計した量の帯域を使用できるようになる。
※1Gbpsの回線2本を仮想的に束ねれば、
2Gbpsの仮想的通信帯域を使用することができる。
 
速度が異なるポートでは
リンクアグリゲーションは組めない。

また、STPが不要な冗長構成をとることも可能。

リンクアグリゲーションにも複数のモードがある。
active Enable LACP unconditionally
auto Enable PAgP only if a PAgP device is detected
desirable Enable PAgP unconditionally
on Enable Etherchannel only
passive Enable LACP only if a LACP device is detected

Ciscoでは

固定モード
LACPモード)
PAgPモード(Cisco独自)
が利用可能。

一般的にはLACPモード(active)を利用する。








■レイヤー2 EtherChannel(switchport)

ポートチャネル1番を作成して、
インターフェースGi0/1とGi0/2を1本として見せる。
LACPアクティブモードを利用。

Catalyst(config)# interface Port-channel1
Catalyst(config-if)# switchport trunk encapsulation dot1q
Catalyst(config-if)# switchport trunk allowed vlan 10
Catalyst(config-if)# switchport mode trunk
Catalyst(config-if)# interface GigabitEthernet0/1
Catalyst(config-if)# switchport trunk encapsulation dot1q
Catalyst(config-if)# switchport trunk allowed vlan 10
Catalyst(config-if)# switchport mode trunk
Catalyst(config-if)# channel-group 1 mode active
Catalyst(config-if)# interface GigabitEthernet0/2
Catalyst(config-if)# switchport trunk encapsulation dot1q
Catalyst(config-if)# switchport trunk allowed vlan 10
Catalyst(config-if)# switchport mode trunk
Catalyst(config-if)# channel-group 1 mode active






■レイヤー3 EtherChannel(routedport)

ポートチャネル1番を作成して、
インターフェースGi0/1とGi0/2を1本として見せる。
LACPアクティブモードを利用。

Catalyst(config)# interface port-channel 1
Catalyst(config-if)# no switchport
Catalyst(config-if)# ip address 10.0.0.1 255.255.255.0
Catalyst(config-if)# interface GigabitEthernet0/1
Catalyst(config-if)# no switchport
Catalyst(config-if)# no ip address
Catalyst(config-if)# channel-group 1 mode active
Catalyst(config-if)# interface GigabitEthernet0/2
Catalyst(config-if)# no switchport
Catalyst(config-if)# no ip address
Catalyst(config-if)# channel-group 1 mode active





■EtherChannel のロードバランシングの種類

送信元MACアドレス    送信元MACアドレスに基づいてポートを決める。
宛先MACアドレス     宛先MACアドレスに基づいてポートを決める。
送信元IPアドレス    送信元IPアドレスに基づいてポートを決める。
宛先IPアドレス     宛先IPアドレスに基づいてポートを決める。
送信元&宛先MACアドレス 送信元&宛先MACアドレスに基づいてポートを決める。
送信元&宛先IPアドレス 送信元&宛先IPアドレスに基づいてポートを決める。






よろしければクリックをお願いします。
にほんブログ村 IT技術ブログ ネットワーク・SEへブログ王ランキングに参加中!



 | HOME |  Next »