FC2ブログ

下流ネットワークエンジニアの生活

上流工程を夢見る下流工程のネットワークエンジニアがネットワーク技術や資格、身の回りのことを情報発信! Juniper Cisco YAMAHA DELL D-Link AlaxalA F5 CCNA CCNP CCIE ネットワークスペシャリスト

指定期間 の記事一覧

Juniper EX4300 でsFlowを有効化 ネットワーク見える化に挑戦

2016.02.24 (Wed)

SNMPでトラフィックを監視していたが、
それ以上のこと(どことの通信が多いか等)を確認したく、
sFlowを設定してみたのでメモ。


■要件
・観測インターフェース :ge-0/0/31
・サンプリングレート  :入/出共に2000
・ポーリング間隔    :60秒
・送信元IPアドレス   :10.0.0.254
・コレクターのIPアドレス:10.0.0.100
・ポート番号(UDP)    :9996







■コンフィグレーション

set protocols sflow collector 10.0.0.100 udp-port 9996
set protocols sflow source-ip 10.0.0.254
set protocols sflow interfaces ge-0/0/31.0 polling-interval 60
set protocols sflow interfaces ge-0/0/31.0 sample-rate ingress 2000
set protocols sflow interfaces ge-0/0/31.0 sample-rate egress 2000


■設定可能値
サンプリングレート:1~1073741823
ポーリング間隔  :0~3600(秒)

スポンサーサイト



Juniper EX4300シリーズにおけるストームコントロール機能 コマンド

2016.02.19 (Fri)

Juniper EX4300シリーズのストームコントロール機能を設定したのでメモ。


閾値は、
ブロードキャスト、マルチキャスト、Unknownユニキャスト
を個々に指定できない。
いわゆるBUMトラフィックの総計でチェックされる。

また、
ブロードキャスト、マルチキャスト、
Unregisteredマルチキャスト、Unknownユニキャスト
をストームコントロールのチェックより外すことが可能。


no-broadcast Disable broadcast storm control
no-multicast Disable multicast storm control
no-registered-multicast Disable registered multicast storm control
no-unknown-unicast Disable unknown unicast storm control
no-unregistered-multicast Disable unregistered multicast storm control


単位は kbps または % で、
設定可能範囲は 100~100000000 kbps または、1~100 %


bandwidth-level Link bandwidth (100..100000000 kbps)
bandwidth-percentage Percentage of link bandwidth (1..100)








■設定例
・ge-0/0/0にストームコントロール(閾値:5000kbps)を適用する。


set forwarding-options storm-control-profiles TEST all bandwidth-level 5000

set interfaces ge-0/0/0 unit 0 family ethernet-switching storm-control TEST



・ge-0/0/0にストームコントロール(閾値:5000kbps)を適用し、
 Unregisteredマルチキャストをチェック対象より除外する。

set forwarding-options storm-control-profiles TEST all bandwidth-level 5000

set interfaces ge-0/0/0 unit 0 family ethernet-switching storm-control TEST
set forwarding-options storm-control-profiles TEST all no-unregistered-multicast

Juniper EXスイッチ トラフィックのレートリミット

2016.02.18 (Thu)
Juniper EXスイッチにおける
VLAN(IRB)インターフェイスでのレートリミット


■用件

・インターフェイスVLAN10配下より10.0.10.0/24宛のICMPパケットを下記に制限する。
 - 200kbps
- バースト1500bytes
・その他のパケットは全て許可する。







■コマンド

set firewall family inet filter icmp_rate-limit term icmp from destination-address 10.0.10.0/24
set firewall family inet filter icmp_rate-limit term icmp from protocol icmp
set firewall family inet filter icmp_rate-limit term icmp then policer icmp
set firewall family inet filter icmp_rate-limit term other then accept

set firewall policer icmp if-exceeding bandwidth-limit 200k
set firewall policer icmp if-exceeding burst-size-limit 1500
set firewall policer icmp then discard

set interface vlan unit 10 family inet filter input icmp_rate-limit


 | HOME |  Next »