FC2ブログ

下流ネットワークエンジニアの生活

上流工程を夢見る下流工程のネットワークエンジニアがネットワーク技術や資格、身の回りのことを情報発信! Juniper Cisco YAMAHA DELL D-Link AlaxalA F5 CCNA CCNP CCIE ネットワークスペシャリスト

YAMAHAルータとCiscoルータ間でのIPSec-VPN設定

2014.03.18 (Tue)
支店のルータにRTX1100を使用していたが故障したため、
余っているCisco1812Jにリプレースした時のメモ

他ベンダー機器間でのIPSec-VPNの構築は、
初めてだったので設定に戸惑った。


■構成

●本社
機種:YAMAHA RTX1100
WAN IPアドレス:A.A.A.A(固定IP)
LAN IPアドレス:192.168.0.0/24

●支社
機種:Cisco Cisco1812J
WAN IPアドレス:B.B.B.B(固定IP)
LAN IPアドレス:192.168.10.0/24







■コンフィグ

●本社 YAMAHA RTXルータ
※RTX1100で確認

ip lan1 address 192.168.0.1/24
ip lan3 address A.A.A.A

tunnel select 1
tunnel endpoint address B.B.B.B
ipsec tunnel 101
ipsec sa policy 101 1 esp 3des-cbc md5-hmac
ipsec ike keepalive use 1 on dpd
ipsec ike local id 1 0.0.0.0/32
ipsec ike pre-shared-key 1 text 共有シークレットキー
ipsec ike remote address 1 B.B.B.B
ipsec ike remote id 1 0.0.0.0/32
tunnel enable 1
!
ipsec use on
ipsec auto refresh on
!
ip route 192.168.10.0/24 gateway tunnel 1




●支店 Ciscoルータ
Cisco1812Jで確認


crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
lifetime 28800
crypto isakmp key 共有シークレットキー address A.A.A.A
crypto isakmp keepalive 10
!
crypto ipsec security-association replay window-size 128
!
crypto ipsec transform-set IPSEC esp-3des esp-md5-hmac
!
crypto ipsec profile VTI
set transform-set IPSEC
!
interface Tunnel0
ip unnumbered Loopback0
tunnel source Dialer1
tunnel destination A.A.A.A
tunnel mode ipsec ipv4
tunnel protection ipsec profile VTI
!
interface FastEthernet1
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Vlan10
ip address 192.168.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1240
!
interface Dialer1
ip address B.B.B.B サブネットマスク
ip mtu 1454
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer-group 1
ppp authentication chap callin
ppp chap hostname PPP認証ID
ppp chap password PPPパスワード
ppp ipcp route default
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 192.168.0.1 255.255.255.0 Dialer1
!
ip nat inside source list 11 interface Dialer1 overload
!
access-list 11 permit 192.168.10.0 0.0.0.255
dialer-list 1 protocol ip permit

関連記事
スポンサーサイト



コメント


管理者のみに表示

トラックバック