FC2ブログ

下流ネットワークエンジニアの生活

上流工程を夢見る下流工程のネットワークエンジニアがネットワーク技術や資格、身の回りのことを情報発信! Juniper Cisco YAMAHA DELL D-Link AlaxalA F5 CCNA CCNP CCIE ネットワークスペシャリスト

BUFFALO L2スイッチ BS-GS20シリーズのコンフィグファイルが.binなのでバイナリデータかと思ったらテキスト形式だった

2019.08.16 (Fri)

BUFFALO L2スイッチ BS-GS20シリーズ
を初めて導入してセットアップを進めているのだが、
この製品はWebGUIからしか設定ができない(CLIが存在しない)

CiscoやJuniperのようにCLIがあれば事前にコンフィグを作っておいて
流し込むだけで済むのでとても効率が良い。

BS-GS20シリーズにおいても、
事前にコンフィグを作っておいてWebGUIで読み込むだけで済めば、
いちちクリックしながら設定をしていくより効率的だと考えた。

WebGUIよりコンフィグのバックアップが取得可能なの
でバックアップをとってみると、なんと、拡張子が.binではないか。。。

あきらめムードでテキストエディタで当該ファイルを開いていみると、
なんと、、、テキスト形式だった!(嬉)






ということで、事前にコンフィグを作って、
WebGUIから読み込むだけでセットアップが終わったという話でした。

大量にBS-GS20シリーズをセットアップ、キッティング、
構築を行う際は是非参考にしていただければと思います。



以下参考(コンフィグデータ)

--------------------------------------------------------------
! -- start of BS-GS2016P config --
! -- Software Version : 1.0.3.36 --
!
enable
config
!
hostname SW-BUFFALO-POE
username_adv "********************************"
!
ip address 192.168.1.1 255.255.255.0
ip default-gateway 192.168.1.254
!
sntp status enable
sntp date 2014/1/1
sntp time 0:2:35
sntp add server 192.168.1.254
!
spanning-tree mst version mstp
spanning-tree mst name 18-C2-BF-xx-xx-xx
!
dhcp-relay relay-to 0.0.0.0
!
mirror group 1 dst-port 1 src-port 2
mirror group 2 dst-port 3 src-port 4
!
system mac-security disable
system learn-limit disable
!
interface vlan1
member 1-16
untagged 1-16
management
ip address 192.168.1.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.1.254
!
interface GigabitEthernet0/1
name "Port 1"
!
interface GigabitEthernet0/2
name "Port 2"
!
interface GigabitEthernet0/3
name "Port 3"
!
interface GigabitEthernet0/4
name "Port 4"
!
interface GigabitEthernet0/5
name "Port 5"
!
interface GigabitEthernet0/6
name "Port 6"
!
interface GigabitEthernet0/7
name "Port 7"
!
interface GigabitEthernet0/8
name "Port 8"
!
interface GigabitEthernet0/9
name "Port 9"
!
interface GigabitEthernet0/10
name "Port 10"
!
interface GigabitEthernet0/11
name "Port 11"
!
interface GigabitEthernet0/12
name "Port 12"
!
interface GigabitEthernet0/13
name "Port 13"
!
interface GigabitEthernet0/14
name "Port 14"
!
interface GigabitEthernet0/15
name "Port 15"
!
interface GigabitEthernet0/16
name "Port 16"
exit
! -- end of configuration --

--------------------------------------------------------------





関連記事
スポンサーサイト



コメント


管理者のみに表示

トラックバック