FC2ブログ

下流ネットワークエンジニアの生活

上流工程を夢見る下流工程のネットワークエンジニアがネットワーク技術や資格、身の回りのことを情報発信! Juniper Cisco YAMAHA DELL D-Link AlaxalA F5 CCNA CCNP CCIE ネットワークスペシャリスト

Cisco - Jinper間でのOSPF - BGP再配送

2013.12.14 (Sat)

Cisco - Jinper間でのOSPF - BGP再配送
設定する機会があったのでメモ




■条件

OSPFよりBGPを優先度を高くする
・ISP/IXPからMXへはフルルートを受信
・MXからIPS/IXPへは内部ネットのみ送信
・Cat6500 - MXへは内部ネットのみ受信
・MXからCat6500へはデフォルトルートのみ送信

・その他は図を参照


cisco-juniper_redistribute_ospf,bgp





コンフィグレーション








●Cat6500

ip routing

vlan 10,20

interface Loopback0
ip address 1.1.1.1 255.255.255.255

interface GigabitEthernet1/0/1
switchport access vlan 10
switchport mode access
interface GigabitEthernet1/0/2
switchport access vlan 20
switchport mode access
interface GigabitEthernet1/6/1
no switchport
ip address a.a.a.a a.a.a.a

interface Vlan10
ip address x.x.x.x y.y.y.y
interface Vlan20
ip address y.y.y.y x.x.x.x

router ospf 100
log-adjacency-changes
passive-interface default
no passive-interface Vlan10
no passive-interface Vlan20
no passive-interface GigabitEthernet1/6/1
network a.a.a.a a.a.a.a area 0
network x.x.x.x y.y.y.y area 1
network y.y.y.y x.x.x.x area 1



●MX

interfaces {
ge-0/0/0 {
unit 0 {
family inet {
address b.b.b.b/b;
}
}
}
xe-0/1/1 {
unit 0 {
family inet {
address a.a.a.a/a;
}
}
}
lo0 {
unit 0 {
family inet {
address 2.2.2.2/32;
}
}
}
}
routing-options {
autonomous-system 自AS番号;
}
protocols {
bgp {
group IXP {
type external;
peer-as 対向AS番号;
neighbor 対向IPアドレス {
export send-IXP
}
}
}
ospf {
preference 180;
external-preference 180;
export send-Cat6500
area 0.0.0.0 {
interface ge-0/0/0 {
}
interface lo0 {
}
}
}
}
policy-options {
policy-statement send-IXP {
term send-IXP {
from {
protocol [ ospf ];
route-filter x.x.x.x/y exact;
route-filter y.y.y.y/x exact;
}
then {
accept;
}
}
}
policy-statement send-Cat6500 {
term send-Cat6500 {
from {
protocol [ bgp ];
route-filter 0.0.0.0/0 exact;
}
then {
external {
type 1;
}
accept;
}
}
}
}



応援クリックをお願いします。
にほんブログ村 IT技術ブログ ネットワーク・SEへブログ王ランキングに参加中!



関連記事
スポンサーサイト



コメント


管理者のみに表示

トラックバック